This is topic ALSA madness... HELP! in forum Ask a Geek! at The Geek Culture Forums!.


To visit this topic, use this URL:
http://www.geekculture.com/cgi-bin/ultimatebb/ultimatebb.cgi?ubb=get_topic;f=12;t=001582

Posted by MacManKrisK (Member # 955) on March 08, 2005, 09:52:
 
I've been trying to get ALSA (the Advanced Linux Sound Archetecture) working on my box for almost 6 months now. I just can not get this to work. I've been through HOW-TO's and everything. Can anyone help?!

I'm running Gentoo Linux with the 2.6.9 kernel. I have two sound cards installed, and I would be equally pleased getting either one to work. One card is a SoundBlaster 16 ISA, the other is reported by "lspci" as "Multimedia audio controller: Cirrus Logic CS 4614/22/24 [CrystalClear SoundFusion Audio Accelerator] (rev 01)."

Anyone able to help? please?
 
Posted by CommanderShroom (Member # 2097) on March 08, 2005, 10:29:
 
I have had issues with ALSA myself. Rather than try to tweak it have you trid running OSS? It works for me, YMMV.
 
Posted by drunkennewfiemidget (Member # 2814) on March 08, 2005, 11:52:
 
With kernel 2.6.9, you should be able to just compile that baby into the kernel and have it work just like that.

If you've enabled OSS emulation, try:

echo hi > /dev/dsp0

Does it just go back to a prompt or do you get "no such device"?

What does dmesg say?

If you get a prompt on the echo, try cat /dev/urandom > /dev/dsp0 (WITH THE VOLUME VERY LOW) ... you should just get a bunch of static out of your speakers.

If you get that far, check permissions on the sound devices.
 
Posted by The Famous Druid (Member # 1769) on March 08, 2005, 12:22:
 
Haven't tried this with sound, but it worked with X-windows config.....

Boot up with Knoppix (which has insanely good hardware detection/configuration) and if the sound works, have a look at the config files Knoppix generated.
 
Posted by jordanv (Member # 3189) on March 08, 2005, 13:42:
 
i assume you have tried running alsaconf as root?

go to your alsa.conf (i think thats what it was) and comment out all the lines reffering to sound devices, let alsaconf sort it out for you.

That worked for me.
 
Posted by MacManKrisK (Member # 955) on March 08, 2005, 20:15:
 
I tried running alsaconf, which got the FLURRY of error down to just this one. HELP!

Does any of this help?

Behemoth root # /etc/init.d/alsasound start
* Loading ALSA modules...
* Loading: snd-card-0...
WARNING: Error inserting snd (/lib/modules/2.6.9-gentoo-r8/kernel/sound/core/snd
.ko): Input/output error [ ok ]
* Restoring Mixer Levels...
* No mixer config in /etc/asound.state, you have to unmute your card! [ !! ]
 
Posted by jordanv (Member # 3189) on March 08, 2005, 21:10:
 
have you edited your /etc/modules.d/alsa?

comment out ALL lines.

run modules-update.

run alsaconf.

thats what fixed it for me.

edit: are you running vanilla or dev kernel?

did you compile manually or run genkernel?
 
Posted by MacManKrisK (Member # 955) on March 13, 2005, 13:49:
 
SUCCESSSSSSSSSSSSSSS!!!!!!!!!!!

I finally got ALSA to work on my linux box with the Cirrus Logic board. [Big Grin]

I had to rebuild my kernel and modules, and I made sure that this time I modularized EVERYTHING required for sound. Then I did a "make clean" before I tried doing anything else, just to make sure I got everything cleared out.

So, after putting the kernel in /boot and double-checking to make sure grub knew what to do with it, I restarted and loaded alsasound by hand. I was amazed when the only error I got was that I hadn't un-muted my card. [Big Grin]

*grooves to The Steve Miller Band, playing on his Linux box*

I'm a picker,
I'm a grinner,
I'm a lover,
and I'm a sinner
I play my music in the sun
.... [Wink]
 
Posted by MacManKrisK (Member # 955) on March 13, 2005, 14:26:
 
Just to threadjack my own thread, I had an interesting post count... right up until I made this post....

 -

Hehe... the same as Tut's member number [Razz]
 


© 2018 Geek Culture

Powered by Infopop Corporation
UBB.classicTM 6.4.0